由于众所周知的原因,本博客会存在打不开的情况,可换个时间再访问。

博客升级至WordPress 2.6.2

公告说明 陈大猫 155℃ 0评论

昨天花了点时间升级了博客,从Wordpress2.5直接升到2.6.2,2.6出来的时候就听说是个过渡版本,看改动也不是很大,就没升了。但这个趋势肯定是要随着新版本的推出而不断跟进的,不然跨越的版本太多怕出问题。

这次升级一切顺利,插件都能用。据说WP会在后续的版本中增加“评论回复”功能,这个对我来说反而恼火,因为目前我用的是偶爱偶家老师出的Wordpress Thread Comment插件,该插件能很好的实现评论回复功能,并且可以自动发送邮件通知回复情况,用的很好。如果WP内置这种功能,不知道会不会产生冲突,卸载掉这款插件也会导致以前的回复显示不正常的。

这次升级唯一出现的小问题是“可视化编辑器”不能工作,也许有朋友记得,当初我升级至2.5的时候也出现这个问题的,“比较关键的一点应该是服务器对Gzip的支持”。当时解决这个问题花了不少时间,最后,在“总统博客”的主人Jiang老师的帮助下顺利解决,这里再次说下解决方法供遇到的朋友们参考:

\wp-includes\js\tinymce下的tiny_mce_config.php这个文件中 compress’ => true,改为 ‘compress’ => false

注意:上面的引号等符号都是英文半角状态输入的。

修改完后再次进入撰写日志界面,按Ctrl+F5强制刷新就可以看到是否恢复正常了。

更新:这次升级还解决了WordPress的ID不连续问题,解决办法来自月光博客,这里简要说下:

在wp-config.php文件中增加一行  define(‘WP_POST_REVISIONS’, false)  同时安装“禁用WordPress自动保存的插件”,在WordPress后台启用此插件。这两个操作缺一不可。

转载请注明:伪医生律师的博客 » 博客升级至WordPress 2.6.2

喜欢 (0)
发表我的评论
取消评论

请点击激活左边的按钮后再提交评论

表情

请单击上面的框后再提交。

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址